The Accomodation of Students

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
Sample Output
No
3
题意问能不能将人分为两部分,每部分的人都互不认识,可以的话输出它的最大匹配数。用vis[i]标记i有没有被访问过,没有的话开始染色。如果出现两个相连的人的颜色相同
则不能分为二分图。
代码:
#include<bits/stdc++.h>
using namespace std;
const int N=250;
int line[N][N];
int ma[N];
int vis[N];
int n,m;
int isTwo()
{
    queue<int >q;
    memset(vis,0,sizeof(vis));
    q.push(1);
    vis[1]=1;
    while(!q.empty())
    {
        int p=q.front();
        q.pop();
        //找与p连接的所有点存不存在冲突
        for(int i=1;i<=n;i++)
        {
            if(line[p][i])//有边
            {
                if(!vis[i])//i未匹配即未被染色。
                {
                    if(vis[p]==1) vis[i]=2;//p的颜色为1则与p相连的颜色为2
                    else vis[i]=1;//
                    q.push(i);
                }
                else if(vis[p]==vis[i]) return 0;
            }
        }
    }
    return 1;
}
int found(int x)//匈牙利找增广路
{
    for(int i=1;i<=n;i++)
    {
        if(!vis[i]&&line[x][i])
        {
            vis[i]=1;
            if(ma[i]==0||found(ma[i]))
            {
                ma[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(ma,0,sizeof(ma));
        memset(line,0,sizeof(line));
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            line[x][y]=line[y][x]=1;
        }
        if(isTwo()&&n!=1)
        {
          int sum=0;
          for(int i=1;i<=n;i++)
          {
            memset(vis,0,sizeof(vis));
            if(found(i)) sum++;
          }
          printf("%d\n",sum/2);
        }
        else printf("No\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值