ACM-二分-POJ-2785-4 Values whose Sum is 0

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2  28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).


主要用到了二分的思想,让我们计算四个的和并不好计算,但是我们可以二分成两个两个的和,分而治之。

然后对两个的和进行排序,让大的和小的(负数)相加,计算结果。代码如下:

/**POJ2785 ------ 2015/4/16*/

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cstdlib>
using namespace std;
const int max_n = 5000;
int a[max_n];
int b[max_n];
int c[max_n];
int d[max_n];
int pre[max_n*max_n];//用来记录前一部分的和
int next1[max_n*max_n];//用来记录后一部分的和
int n;
/**返回A是否大于B 按降序排列*/
bool com_max(int a,int b)
{
    return a>b;
}
int main()
{
    //freopen("POJ2785.txt","r",stdin);
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d %d %d %d",a+i,b+i,c+i,d+i);
    }
    int index = 0;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            pre[index] = a[i] + b[j];
            next1[index] = c[i] + d[j];
            index++;
        }
    }
    //sort(pre,pre+index,com_max);
    //sort(next1,next1+index,com_max);
    sort(pre,pre+index);
    sort(next1,next1+index);
    int r = index-1;
    int res = 0;
    for(int i=0;i<index;i++)
    {
        /**pre是从大到小开始,next是从小到大开始*/
        while(r>=0 && pre[i]+next1[r]>0)
        {
            //说明在i不变的情况下,next太小,得增加
            r--;
        }
        if(r<0)
        {
            //查询完成
            break;
        }
        /**
        if((pre[i]+next1[r]) == 0)
        {
            res++;
            r--;
        }
        */
        /**一个i可能对应多个解*/
        int temp = r;
        while(temp >=0 && (pre[i]+next1[temp])==0)
        {
            res++;
            temp--;
        }
    }
    printf("%d\n",res);
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值