POJ 2785 4 Values whose Sum is 0 (对半分解 二分搜索)


4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 17658 Accepted: 5187
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

Southwestern Europe 2005

题目链接:http://poj.org/problem?id=2785

题目大意:给四组数,一列为一组,从每组中取一个出来使得四个相加为0,问有多少种方案

题目分析:a + b + c + d = 0  ==> a + b = -c -d,我们先预处理出前两组能组成的值,复杂度为n^2,然后排序后二分查找,这里最简便的方法是分别求出upper_bound(num, num + cnt, -c-d) - num,lower_bound(num, num + cnt, -c-d) - num,前者表示num数组里大于-c-d的第一个位置,后者表示num数组里大于等于-c-d的第一个位置,然后一减就得到与-c-d相等的个数

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
#include <iostream>
#define ll long long
using namespace std;
int const MAX = 4e3 + 5;
int a[MAX], b[MAX], c[MAX], d[MAX];
int num[MAX * MAX];

int main()
{   
    int n;
    while(scanf("%d", &n) != EOF)
    {
        ll ans = 0;
        int cnt = 0;
        for(int i = 1; i <= n; i++)
            scanf("%d %d %d %d", &a[i], &b[i], &c[i], &d[i]);
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                num[cnt ++] = a[i] + b[j];
        sort(num, num + cnt);
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                int tmp = -c[i] - d[j];
                int t1 = lower_bound(num, num + cnt, tmp) - num;
                int t2 = upper_bound(num, num + cnt, tmp) - num;
                ans += (ll)(t2 - t1);
            }
        }
        cout << ans << endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值