HDU 1312 dfs、bfs

32 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1312

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题目大意:给你一张图,@表示初始化时人的位置,.表示黑瓷砖,#表示红瓷砖,这个人只能在黑瓷砖上移动,问你他能到达的黑瓷砖的个数。

思路:从初始位置开始,dfs、bfs遍历图,同时统计走过的黑瓷砖个数即可。每次可以选择上下左右四个方向,走过的设一个标记就不要再走了。我用的是dfs的方法。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;
using namespace std;

int d[4][2]={{-1,0},{0,-1},{1,0},{0,1}};

char s[30][30];
int flag[30][30];
int n,m;
int cnt=1;

void solve(int dx,int dy);

int main()
{
	while(~scanf("%d%d",&m,&n)&&n&&m)
	{
		int dx=0,dy=0;
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
				cin>>s[i][j];
				if(s[i][j]=='@')
					dx=i,dy=j;
			}
		}
		memset(flag,0,sizeof(flag));
		flag[dx][dy]=1;
		cnt=1;
		solve(dx,dy);
		printf("%d\n",cnt);
	}
	return 0;
}

void solve(int x,int y)
{
	if(x<0||x>=n||y<0||y>=m)
		return ;
	for(int i=0;i<4;i++)
	{
		int dx=x+d[i][0];
		int dy=y+d[i][1];
		if(dx>=0&&dx<n&&dy>=0&&dy<m&&s[dx][dy]!='#'&&!flag[dx][dy])
		{
			cnt++;
			flag[dx][dy]=1;
			solve(dx,dy);
		}
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值