HDU 3139 模拟水题

http://acm.hdu.edu.cn/showproblem.php?pid=3139


Tim is an absolutely obsessive soda drinker, he simply cannot get enough. Most annoyingly though, he almost never has any money, so his only obvious legal way to obtain more soda is to take the money he gets when he recycles empty soda bottles to buy new ones. In addition to the empty bottles resulting from his own consumption he sometimes find empty bottles in the street. One day he was extra thirsty, so he actually drank sodas until he couldn't afford a new one.

Input

Three non-negative integers e, f, c, where e < 1000 equals the number of empty soda bottles in Tim's possession at the start of the day, f < 1000 the number of empty soda bottles found during the day, and 1 < c < 2000 the number of empty bottles required to buy a new soda.

Output

How many sodas did Tim drink on his extra thirsty day?

Sample Input

9 0 3
5 5 2

Sample Output

4
9

题目大意:给出Tim每天所拥有的空瓶子数、捡到的空瓶子数、几个空瓶子能换一瓶饮料,求Tim今天最多能喝几瓶饮料。

思路:模拟水题。一瓶饮料喝完也算一个空瓶子。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;

int a,b,c;

int main()
{
    while(~scanf("%d %d %d",&a,&b,&c))
    {
        int sum=0;
        a+=b;
        while(a>=c)
        {
            sum+=a/c;
            a=a/c+a%c;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值