[ACM] POJ 3071 Football (概率DP)

286 篇文章 140 订阅
14 篇文章 0 订阅

Football
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2875 Accepted: 1462

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source


解题思路:

题意为有2^n次方个队,已知任意两个队之间每个队获胜的概率,比赛的规则相邻的两个队伍之间比赛,赢的继续下一轮,输的直接淘汰(相邻的两个队伍是指,  1,2     3,4    5,6.......也就是说2和3 不比赛。如果1,2中假设1赢了,1再跟3,4中的赢家比赛,这样最后赢的那个队一共打了n场比赛。

我们用dp[ i ][ j ]表示j参加的第i场比赛赢的概率,那么有 递推方程  dp [ i ] [ j ]  =   dp [ i -1  ] [ j ] *dp [ i -1 ] [ k ] *p [ j ] [ k ],j参加的第i场比赛赢,那么 j参加的第i-1场比赛肯定赢,所以有dp[i-][j] ,  第i场比赛j的对手是k,j赢,所以有 p[ j ] [ k ], 那么既然k也能够打到第i场比赛,那说明k打的第i-1场比赛也一定赢,所以有 dp[ i-1 ] [ k ].

三者相乘即为dp[i][j]. 

所以现在有一个问题,第i场比赛j的对手k是谁? 

我们把 1 - 2^n 的队伍编号 0 - 2^n-1,  假设n=3,那么每个队伍以及比赛情况可表示为


第一场比赛: 00    VS    01

第一场比赛: 10    VS    11

第一场比赛:  100  VS  101

第一场比赛:  110  VS    111

注意这里所说的第几场比赛并不是所有队的比赛总数,而是具体到某一个队,该队所参加的比赛场数。

观察一下, 第1场比赛的队伍二进制右起第0位(位数从0开始,下面也是这样)是相反的。

下面第二场比赛 

假设第一场比赛中  00 胜出,  10胜出,100胜出,111胜出,那么 

第二场比赛: 00  VS  10

第二场比赛: 100 VS 111

观察一下,第2场比赛的队伍二进制右起第1位是相反的。

假设第二场比赛中10 胜出,111胜出,那么

第三场比赛:  10 VS 111

观察一下,第3场比赛的队伍二进制右起第2位是相反的。 10表示为010 

所以就有了这样的结论,在进行第i场比赛地时候,参加比赛的队伍编号二进制中第i-1位是相反的。

比如第i场比赛时候有j,k,    那么  j>>(i-1)  ^1     = =     k>>(i-1)  ,  j>>(i-1)意思是把j的右数i-1位以后的都去掉,最后一位成为原来的i-1位.    ^1是对其取反,0^1= 1    1^1=0

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=(1<<7)+1;
double dp[8][maxn];//第i场比赛j赢
double p[maxn][maxn];
int n;

int main()
{
    while(scanf("%d",&n)!=EOF&&n!=-1)
    {
        for(int i=0;i<(1<<n);i++)
            for(int j=0;j<(1<<n);j++)
            scanf("%lf",&p[i][j]);

        memset(dp,0,sizeof(dp));//初始化
        for(int j=0;j<(1<<n);j++)
            dp[0][j]=1;

        for(int i=1;i<=n;i++)
            for(int j=0;j<(1<<n);j++)
            for(int k=0;k<(1<<n);k++)
        {
            if((j>>(i-1)^1)==(k>>(i-1)))//二进制第i-1位(从0位开始),不同才有可能称为对手,^1是对第i-1位取反
                dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
        }
        int ans;
        double  MAX=-1;
        for(int i=0;i<(1<<n);i++)
            if(dp[n][i]>MAX)
        {
            ans=i+1;
            MAX=dp[n][i];
        }
        cout<<ans<<endl;
    }
    return 0;
}






  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值