hdu1754 I Hate It 线段树模板

Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9

Hint

题意

题解:

注意该题为更改操作

AC代码

#include<stdio.h>
#include <math.h>
#include <cstring>
#include<algorithm>
using namespace std;
const int MAXN = 2e5+5;
struct node{
    int mx,sm;
}tree[MAXN<<2];

void Buildtree(int o,int l,int r){
    if (l == r){
        int t;
        scanf("%d",&t);
        tree[o].mx = tree[o].sm = t;
        return ;
    }
    int mid = (l+r)>>1;
    Buildtree(o<<1,l,mid);
    Buildtree(o<<1|1,mid+1,r);
    tree[o].mx = max(tree[o<<1].mx,tree[o<<1|1].mx);
    tree[o].sm = tree[o<<1].sm + tree[o<<1|1].sm;
}

void Update(int o,int l,int r,int x,int y){
    if (l == r){
        tree[o].mx = tree[o].sm = y;
        return ;
    }
    int mid = (l+r)>>1;
    if (x > mid) Update(o<<1|1,mid+1,r,x,y);
    else Update(o<<1,l,mid,x,y);
    tree[o].mx = max(tree[o<<1].mx,tree[o<<1|1].mx);
    tree[o].sm = tree[o<<1].sm + tree[o<<1|1].sm;
}

int Querymax(int o,int l,int r,int x,int y){
    if (l ==x&& r == y){
        return tree[o].mx;
    }
    int mid = (l+r)>>1;
    if (x>mid)  return Querymax(o<<1|1,mid+1,r,x,y);
    else if (y <= mid)  return Querymax(o<<1,l,mid,x,y);
    else return max(Querymax(o<<1,l,mid,x,mid),Querymax(o<<1|1,mid+1,r,mid+1,y));
}
int main()
{
    int n,m;
    while (scanf("%d%d",&n,&m)!=EOF){
        memset(tree,0,sizeof(tree));
        Buildtree(1,1,n);
        char st[10];
        int a,b;
        while (m--){
            scanf("%s",st);
            if (st[0] == 'Q'){
                scanf("%d%d",&a,&b);
                printf("%d\n",Querymax(1,1,n,a,b));
            }else {
                scanf("%d%d",&a,&b);
                Update(1,1,n,a,b);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值