HDU5980 Find Small A

Find Small A

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 385    Accepted Submission(s): 197


Problem Description
As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).
 

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ ai ≤2^32 - 1) follow
 

Output
Output one line,including an integer representing the number of 'a' in the group of given numbers.
 

Sample Input
  
  
3 97 24929 100
 

Sample Output
  
  
3
 

Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)  

http://acm.split.hdu.edu.cn/showproblem.php?pid=5980

看谁翻译快 给N个数 每个数都可以拆开成一个32位的2进制 每八位一个字节  每个字节的2进制数换算成十进制的看有多少个97

#include<bits/stdc++.h>
using namespace std;
int aa[35];
int main()
{   int ans,cnt,n,m,k,i;
    while(scanf("%d",&n)!=EOF)
    {
        ans=0;
        while(n--)
        {
            scanf("%d",&m);
            memset(aa,0,sizeof(aa));
            k=0;
            while(m)
            {
                aa[k++]=m&1;
                m=m>>1;//被自己坑一手
            }
               cnt=0;
            for(i=0; i<8&&i<k; i++)
                cnt+=aa[i]*pow(2,i);
                if(cnt==97) ans++;
                cnt=0;
            for(i=0; i<16&&i<k; i++)
                cnt+=aa[i]*pow(2,i-8);
                if(cnt==97) ans++;
                cnt=0;
            for(i=0; i<24&&i<k; i++)
                cnt+=aa[i]*pow(2,i-16);
                if(cnt==97) ans++;
                cnt=0;
            for(i=0; i<32&&i<k;i++)
                cnt+=aa[i]*pow(2,i-24);
                if(cnt==97) ans++;
        }
       printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值