1012. The Best Rank (25)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - CProgramming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encouragestudents by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and theaverage grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A

提交代码

第一次提交的时候,没有在意算平均值的时候的四舍五入问题。

导致下面的错误,第三个测试点无法通过。



修改之后,得到正确的了。

涉及的知识点为,vector的排序。

然后就是名次一样的情况。1 1 1 4.。。。。。。



#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
#define MAX(a,b) (a)>(b)?(a):(b)

struct Stu
{
	string id;
	int C;
	int M;
	int E;
	int A;
	int rank;
	int rankindex;
};

int N,M;
vector<Stu> vstu;
char CN[4][2]={"C","M","E","A"};

bool cmpbya(Stu a, Stu b)
{
	return a.A>b.A;
}
bool cmpbyc(Stu a, Stu b)
{
	return a.C>b.C;
}
bool cmpbym(Stu a, Stu b)
{
	return a.M>b.M;
}
bool cmpbye(Stu a, Stu b)
{
	return a.E>b.E;
}

int findid(string tid)
{
	for(int i=0; i<N; i++)
	{
		if(vstu[i].id==tid)
		{
			return i;
		}
	}
	return -1;
}

int main(int argc, char** argv) {
	scanf("%d %d",&N,&M);
	
	for(int i=0; i<N; i++)
	{
		string tid;
		int tc,tm,te,ta;
		Stu ts;
		cin>>tid>>tc>>tm>>te;
		ta=(int)((tc+tm+te)/3.0+0.5);
		ts.id=tid;
		ts.C=tc;
		ts.M=tm;
		ts.E=te;
		ts.A=ta;
		vstu.push_back(ts);
	}
	
	for(int i=0; i<M; i++)
	{
		string ttid;
		int tmp;Stu tts;
		cin>>ttid;
		tmp=findid(ttid);
		if(tmp == -1)
		{
			printf("N/A\n");
			continue;
		}
		int rank0,rank1,rank2,rank3;
		int j=0;
		sort(vstu.begin(),vstu.end(),cmpbya);
		rank0=tmp=findid(ttid);
		j=tmp-1;
		while(j>=0)
		{
			if(vstu[j].A==vstu[tmp].A)
			{
				rank0=j;
			}
			j--;
		}
		sort(vstu.begin(),vstu.end(),cmpbyc);
		rank1=tmp=findid(ttid);
		j=tmp-1;
		while(j>=0)
		{
			if(vstu[j].C==vstu[tmp].C)
			{
				rank1=j;
			}
			j--;
		}
		sort(vstu.begin(),vstu.end(),cmpbym);
		rank2=tmp=findid(ttid);
		j=tmp-1;
		while(j>=0)
		{
			if(vstu[j].M==vstu[tmp].M)
			{
				rank0=j;
			}
			j--;
		}
		sort(vstu.begin(),vstu.end(),cmpbye);
		rank3=tmp=findid(ttid);
		j=tmp-1;
		while(j>=0)
		{
			if(vstu[j].E==vstu[tmp].E)
			{
				rank3=j;
			}
			j--;
		}
		if ((rank0 <= rank1) && (rank0 <= rank2) && (rank0 <= rank3)){
            cout << rank0+1 << " " << "A" << endl;
        }
        else if ((rank1 < rank0) && (rank1 <= rank2) && (rank1 <= rank3)){
            cout << rank1+1 << " " << "C" << endl;
        }
        else if ((rank2 < rank0) && (rank2 < rank1) && (rank2 <= rank3)){
            cout << rank2+1 << " " << "M" << endl;
        }
        else{
            cout << rank3+1 << " " << "E" << endl;
        }
	}
	
	return 0;
}




基于STM32F407,使用DFS算法实现最短迷宫路径检索,分为三种模式:1.DEBUG模式,2. 训练模式,3. 主程序模式 ,DEBUG模式主要分析bug,测量必要数据,训练模式用于DFS算法训练最短路径,并将最短路径以链表形式存储Flash, 主程序模式从Flash中….zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值