1038. Recover the Smallest Number (30)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

提交代

——————————

简单题目,

在leetcode上面见过类似的题目,leetcode上面为找到最大的数,这个题目类似

之所以没有一步正确,主要是因为自己没有考虑到前面几个均为0.


#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>

using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int N;
bool cmp(string s1, string s2){
	return (s1+s2)<(s2+s1);
}
int main(int argc, char** argv) {
	vector<string> v;
	string ans;
	int i=0;
	
	scanf("%d",&N);
	for(i=0; i<N; i++){
		string tmp;
		cin>>tmp;
		v.push_back(tmp);
	}
	sort(v.begin(),v.end(),cmp);
	for(i=0; i<v.size(); i++) ans=ans+v[i];//左加
	bool flag=false;
	for(i=0; i<ans.size(); i++){
		if(ans[i]=='0'&&!flag){
			if(i==ans.size()-1){
				printf("0");
			}
			continue;
		}else{
			cout<<ans[i];
			flag=true;
		}
	}

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值