1139 First Contact 甲级 xp_xht123

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

解题思路:这道题坑的一匹,读入数据如果用整数读入的话,输出的结果总是很奇怪,因为有可能会出现-0000和0000的出现,这表示的是一个是男生一个是女生,因此需要使用字符串读入。如果使用cin读入的话会多一个回车或者多一个空格,因此使用scanf读入,最后转换为string就行。

这道题用邻接矩阵显然无法存储,需要使用哈希表,将每一个字符串映射成0 ~ 300,因此需要使用一个哈希表和一个一维数组存储映射的结果和key值,映射完之后,将男孩和女孩的编号分别存一下,有利于以下的操作,只是存完的时候注意去重。

再注意一个很离谱的地方的就是同性之间有可能有关系,所以在最后判断的时候可以采用如下的方案

给定一对人 a 和 b
需要判断与a相连的c 和 与b相连的d
c和d是否相连即可

最后注意,需要递增输出,最后sort一下就行 

/*
给定一对人 a 和 b
需要判断与a相连的c 和 与b相连的d
c和d是否相连即可
*/

#include<iostream>
#include<unordered_map>
#include<vector>
#include<algorithm>
#include<cstring>

using namespace std;
const int N = 310;
int n , m;
unordered_map<string , int>mp;//将某一个人映射成0 ~ 300之间的数
string num[N];
int id;
bool g[N][N];
vector<int>boys , girls;

void _unique(vector<int>&v)
{//vector去重使用unique和erase函数
    sort(v.begin() , v.end());
    v.erase( unique(v.begin() , v.end()) , v.end() );
}

int main()
{
    //注意使用scanf 如果有cin和scanf同时使用有可能会多也可能少个回车或空格
    scanf("%d %d" , &n , &m);
    while(m --)
    {
        //因为会有-0000 和 0000存在
        //坑点 一条信息是一个字符串
        /*
        string a , b;
        cin >> a >> b;
        */
        char a[N] , b[N];
        scanf("%s %s" , a , b);
        
        string x = a , y = b;
        if(x.size() == 5) x = x.substr(1);
        if(y.size() == 5) y = y.substr(1);
        //map count函数可以得到某一个key值是否在map中存在
        if(mp.count(x) == 0) mp[x] = ++ id , num[id] = x;
        if(mp.count(y) == 0) mp[y] = ++ id , num[id] = y;
        
        int mx = mp[x] , my = mp[y];//得到映射后的结果
        g[mx][my] = g[my][mx] = true;
        
        if(a[0] == '-') girls.push_back(mx);
        else boys.push_back(mx);
        
        if(b[0] == '-') girls.push_back(my);
        else boys.push_back(my);
    }
    
    _unique(boys);
    _unique(girls);
    
    
    int k;
    scanf("%d",&k);
    while(k --)
    {
        vector< pair<string , string> >res;
        /*
        string a , b;
        cin >> a >> b;
        */
        char a[N] , b[N];
        scanf("%s %s" , a , b);
        vector<int>p = boys , q = boys;
        string x = a , y = b;
        if(a[0] == '-') p = girls , x = x.substr(1);
        if(b[0] == '-') q = girls , y = y.substr(1);
        
        int mx = mp[x] , my = mp[y];//字符映射成数字
        //题目有可能会有同性之间的(虽然听起来挺离谱的)
        for(int c : p)
            for(int d : q)
            {
                if(c != mx && c != my && d != mx && d != my && g[mx][c] && g[c][d] && g[d][my])
                    res.push_back({num[c] , num[d]});//存储映射以前的结果
            }
        
        sort(res.begin() , res.end());
        cout << res.size() << endl;
        for(auto i : res)
            cout << i.first << " " << i.second << endl;
    }
    return 0;
}

总之,这是一道很坑的题。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值