HDU-6197 - array array array - 最长上升或下降子序列

链接:

  http://acm.hdu.edu.cn/showproblem.php?pid=6197


题目:

Problem Description

One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo’s path to escape from the museum. But Kiddo didn’t want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: “I have an array A and a number k, if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. ” Conan: “emmmmm…” Now, Conan seems to be in trouble, can you help him?

Input

The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2,,An .
1T20
1n105
0kn
1Ai105

Output

For each test case, please output “A is a magic array.” if it is a magic array. Otherwise, output “A is not a magic array.” (without quotes).

Sample Input

3
4 1
1 4 3 7
5 2
4 1 3 1 2
6 1
1 4 3 5 4 6

Sample Output

A is a magic array.
A is a magic array.
A is not a magic array.


题意:

  给出一个序列,问能否去掉k的数之后使得整个序列不是递增也不是递减的。


思路:

  求一遍最长上升或下降子序列的最大长度,然后判断是否大于等于 nk


实现:

#include <bits/stdc++.h>
using namespace std;
const int maxn = int(2e6)+7;
int a[maxn], tmp[maxn], T, n, k;
int solve() {
    memset(tmp, 0, sizeof(tmp));
    tmp[0] = a[0];
    int len1 = 1, len2 = 1;
    for(int i=1 ; i<n ; i++) {
        if(a[i] > tmp[len1-1]) tmp[len1++] = a[i];
        else {
            int pos = int(lower_bound(tmp, tmp+len1, a[i]) - tmp);
            tmp[pos] = a[i];
        }
    }
    memset(tmp, 0, sizeof(tmp));
    tmp[0] = a[0];
    for(int i=1 ; i<n ; i++) {
        if(a[i] < tmp[len2-1]) tmp[len2++] = a[i];
        else {
            int pos = int(lower_bound(tmp, tmp+len2, a[i], greater<int>()) - tmp);
            tmp[pos] = a[i];
        }
    }
    return max(len1, len2);
}
int main() {
    scanf("%d", &T);
    while(T--) {
        scanf("%d%d", &n, &k);
        for(int i=0 ; i<n ; i++) scanf("%d", a+i);
        puts((solve() >= n-k ? "A is a magic array." : "A is not a magic array."));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值