PAT-A-1054 The Dominant Color

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2
​24
​​ ). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:
For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
方法1:用map来求解奖励map<int,int> cnt 作为数字与出现次数的映射关系

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <string.h>
#include <math.h>
using namespace std;

int main(){
    int n,m,col;
    map<int,int> cnt;
    scanf("%d%d",&m,&n);
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            scanf("%d",&col);
            if(cnt.find(col)!=cnt.end()){
                cnt[col]++;//若已存在就次数加一
            }else{
                cnt[col]=1;//若不存在次数置为1
            }
        }
    }
    int k=0,MAX=0;//最大数字及该数字出现次数
    for(map<int,int>::iterator it=cnt.begin();it!=cnt.end();it++){
        if(it->second>MAX){
            k=it->first;
            MAX=it->second;
        }
    }
    printf("%d\n",k);
    // system("pause");
    return 0;
}

方法2:设置cnt和ans,cnt负责计数,ans负责记录答案,遇到相等的cnt加1,遇到不等的cnt减1,当cnt变为0时,将ans换为新的数,cnt重置为1

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <string.h>
#include <math.h>
using namespace std;

int main()
{
    int n, m, col;
    scanf("%d%d", &m, &n);
    int ans, cnt; //ans为众数,cnt为这个数出现的次数
    for (int i = 0; i < n; i++)
    {
        for (int j = 0; j < m; j++)
        {
            scanf("%d", &col);
            if (i == 0 && j == 0)
            {
                cnt = 1;
                ans = col;
            }
            else
            {
                if (col == ans)//如果依旧是这个数
                {
                    cnt++;
                }
                else//如果不是这个数
                {
                    cnt--;
                    if (cnt == 0)
                    { //如果cnt为0令新数字为ans
                        ans = col;
                        cnt++; //cnt重新置为1
                    }
                }
            }
        }
    }
    printf("%d\n",ans);
    // system("pause");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值