PAT-A-1043 Is It a Binary Search Tree (25分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
代码如下:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <string.h>
#include <math.h>
using namespace std;
struct node
{
    int data;
    node *left,*right;
};
void insert(node* &root,int data){//root需要引用,因为再构造数
    if(root==NULL){//到达空结点,即需要插入的位置
        root=new node;
        root->data=data;
        root->left=root->right=NULL;
        return;
    }
    if(data<root->data){//插在左子树
        insert(root->left,data);
    }else{             //插在右子树
        insert(root->right,data);
    }
}
//先序遍历,结果存在vi
void preOrder(node *root,vector<int> &vi){
    if(root==NULL){
        return;
    }
    vi.push_back(root->data);
    preOrder(root->left,vi);
    preOrder(root->right,vi);
}
void preOrderMirror(node *root,vector<int> &vi){
    if(root==NULL){
        return;
    }
    vi.push_back(root->data);
    preOrderMirror(root->right,vi);
    preOrderMirror(root->left,vi);
}
void postOrder(node *root,vector<int> &vi){
    if(root==NULL){
        return;
    }
    postOrder(root->left,vi);
    postOrder(root->right,vi);
    vi.push_back(root->data);
}
void postOrderMirror(node *root,vector<int> &vi){
    if(root==NULL){
        return;
    }
    postOrderMirror(root->right,vi);
    postOrderMirror(root->left,vi);
    vi.push_back(root->data);
}
//origin为初始序列 pre post为先序、后序,preM,postM 为镜像树先序后序
vector<int> origin,pre,post,preM,postM;
int main(){
    int n,data;
    node *root =NULL;
    scanf("%d",&n);
    for(int i = 0 ; i < n ; i ++){
        scanf("%d",&data);
        origin.push_back(data);
        insert(root,data);
    }
    preOrder(root,pre);
    preOrderMirror(root,preM);
    postOrder(root,post);
    postOrderMirror(root,postM);
    if(origin==pre){
        printf("YES\n");
        for(int i = 0 ; i < post.size() ; i ++){
            printf("%d",post[i]);
            if(i<post.size()-1){
                printf(" ");
            }else{
                printf("\n");
            }
        }
    }else if(origin==preM){
        printf("YES\n");
        for(int i = 0 ; i < postM.size() ; i ++){
            printf("%d",postM[i]);
            if(i<postM.size()-1){
                printf(" ");
            }else{
                printf("\n");
            }
        }
    }else{
        printf("NO\n");
    }
    // system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值