Find The Multiple POJ - 1426 深搜

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100

111111111111111111

题意:

给出一个数n,求出它的倍数x,这个倍数只由0和1组成。答案不唯一。

题解:

应用深搜,起始的数字x必须为1,每一次搜索得到的数为x=x*10或现在想x*10+1,否和只有1或0的条件,每次得到一个数都判断是否能整除n,如果能就标记,代表得到答案。因为n在200以内,经推断x的值long long int 可以存储。所以判断条件为是否标记和x的数值是否在long long int 范围内。

代码如下:

#include<stdio.h>
#include<string.h>

int n,flag;

void dfs(int step,long long int x)
{
    if(flag==1 || step>18)
        return;
    if(x%n==0)
    {
        flag=1;
        printf("%lld\n",x);
        return;
    }
        dfs(step+1,x*10);
        dfs(step+1,x*10+1);
}
int main()
{
    while(~scanf("%d",&n) && n)
    {
        flag=0;
        dfs(0,1);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值