HODJ刷题(1090)

A+B for Input-Output Practice (II)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 71613    Accepted Submission(s): 46450

Problem Description
Your task is to Calculate a + b.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line. 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 
Sample Input
  
  
2 1 5 10 20
 
Sample Output
  
  
6 30
 

这里给出两种参考,均accepted
参考1:
#include <stdio.h>

int main()
{
    int n, a, b;
    scanf("%d", &n);
    while(n--)
    {
        scanf("%d%d", &a, &b);
        printf("%d\n", a+b);
    }
    return 0;
}


参考2:
#include <stdio.h>

int main()
{
    int n, a, b, i;
    while(scanf("%d", &n) !=EOF)
    {
        for(i=0; i<n; i++)
        {
            while(scanf("%d%d", &a, &b) !=EOF)
                printf("%d\n", a+b);
        }
    }
    return 0;
}

其中第一种方法花费的时间更少


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值