server 上pip安装pytorch遇到问题imdbpy 5.0 requires FormEncode, which is not installed.等

问题:

Processing ./torch-0.2.0.post3-cp27-cp27mu-manylinux1_x86_64.whl

Requirement already satisfied: numpy in /usr/lib/python2.7/dist-packages (from torch==0.2.0.post3) (1.11.0)

Requirement already satisfied: pyyaml in /usr/lib/python2.7/dist-packages (from torch==0.2.0.post3) (3.11)

imdbpy 5.0 requires FormEncode, which is not installed.

imdbpy 5.0 requires SQLAlchemy, which is not installed.

imdbpy 5.0 requires sqlalchemy-migrate, which is not installed.

imdbpy 5.0 requires SQLObject, which is not installed.

Installing collected packages: torch

Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/torch-0.2.0.post3.dist-info'

Consider using the `--user` option or check the permissions.

 

解决:

pip install --user   安装包

展开阅读全文

没有更多推荐了,返回首页