Genealogical tree(POJ 2367)

Genealogical tree

      Time Limit: 1000MS        Memory Limit: 65536K

Description
The system of Martians’ blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there’s nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input
The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member’s children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output
The standard output should contain in its only line a sequence of speakers’ numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input
5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output
2 4 5 3 1

Source
http://poj.org/problem?id=2367

这个题是简单的拓扑排序

AC的代码

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define V 510   //最大顶点数
int G[V][V];    //图
int degree[V];  //记录各顶点的入度
void topological_sort(int n)    //拓扑排序函数
{
    int i, j, k;
    int flag = 0;
    for(i = 1; i <= n; i++){
        for(j = 1; j <= n; j++){
            if(degree[j] == 0){     //找到入度为0的顶点
                if(!flag){
                    printf("%d", j);    //输出
                    flag = 1;
                }
                else
                    printf(" %d", j);
                degree[j]--;        //将其入度减为-1
                k = j;              //用k记录此顶点
                break;
            }
        }
        for(j = 1; j <= n; j++){
            if(G[k][j] == 1){
                G[k][j] = 0;    //标记
                degree[j]--;    //将找到的顶点的入度减一
            }
        }
    }
}
int main(void)
{
    int i, j, k;
    int n;
    scanf("%d", &n);
    memset(G, 0, sizeof(G));            //图的初始化
    memset(degree, 0, sizeof(degree));  //顶点入度的初始化
    for(i = 1; i <= n; i++){
        int u,v;
        while(1){
            scanf("%d", &v);
            if(!v)
                break;
            if(!G[i][v]){
                G[i][v] = 1;
                degree[v]++;
            }
        }
    }
    topological_sort(n);    //调用拓扑排序函数
    printf("\n");
    return 0;
}
  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值