ACM第五届山东省赛 F-Full Binary Tree

ACM第五届山东省赛 F-Full Binary Tree

Time Limit: 2000 ms  Memory Limit: 65536 KiB

Problem Description
In computer science, a binary tree is a tree data structure in which each node has at most two children. Consider an infinite full binary tree (each node has two children except the leaf nodes) defined as follows. For a node labelled v its left child will be labelled 2 * v and its right child will be labelled 2 * v + 1. The root is labelled as 1.
You are given n queries of the form i, j. For each query, you have to print the length of the shortest path between node labelled i and node labelled j.

Input
First line contains n(1 ≤ n ≤ 10^5), the number of queries. Each query consists of two space separated integers i and j(1 ≤ i, j ≤ 10^9) in one line.

Output
For each query, print the required answer in one line.

Sample Input
5
1 2
2 3
4 3
1024 2048
3214567 9998877

Sample Output
1
2
3
1
44

题目链接:http://acm.sdut.edu.cn/onlinejudge2/index.php/Home/Index/problemdetail/pid/2882.html

本题的题意:给定满二叉树上的两个点,求它们之间的路径长度。
很容易想到的解法是将结点编号大的除以二,以此循环,每次计路径数加一,直到两个结点的编号相等。

参考代码

#include <stdio.h>
int main(void)
{
    int n;
    int i, j;
    int sum;
    scanf("%d", &n);
    while(n--){
        sum = 0;
        scanf("%d%d", &i, &j);
        while(i != j){
            if(i > j){
                i /= 2;
                sum++;
            }
            else{
                j /= 2;
                sum++;
            }
        }
        printf("%d\n", sum);
    }
    return 0;
}
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值