POJ1664放苹果

Description
We are going to place M same apples into N same plates.
There could be some empty plates.
How many methods do we have?
When we have 7 applesand 3 plates, the methods, (1, 5, 1) and (5, 1, 1) are the same.
Input
The first line is the number of test cases, t. 0<=t<=20
The next t lines are test cases containing two numbers, M and N. 1<=M, N<=10.
Output
Output the numbers of method in each test case in one line.
Sample Input
1
7 3
Sample Output

8

代码:

#include<stdio.h>
#include<stdlib.h>
int fu(int m,int n){
if(m==0||n==1)return 1;
if(m<n) return fu(m,m);
else return fu(m-n,n)+fu(m,n-1);}
int main(){
int m,n;
int t;
scanf("%d",&t);
while(t>0){
	scanf("%d %d",&m,&n);
	printf("%d\n",fu(m,n));
t--;}
return 0;}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值