[4931]:Happy Three Friends

Problem Description
Dong-hao , Grandpa Shawn , Beautful-leg Mzry are good friends. One day , they want to play a game.

There are 6 numbers on the table.

Firstly , Dong-hao can change the order of 6 numbers.

Secondly , Grandpa Shawn take the first one and the last one , sum them up as his scores.

Thirdly , Beautiful-leg Mzry take any of 3 numbers from the last 4 numbers , and sum them up as his scores.

Finally , if Grandpa Shawn’s score is larger than Beautiful-leg Mzry’s , Granpa Shawn wins!

If Grandpa Shawn’s score is smaller than Beautiful-leg Mzry’s , Granpa Shawn loses.

If the scores are equal , there is a tie.

Nowadays , it’s really sad that Grandpa Shawn loses his love. So Dong-hao wants him to win(not even tie). You have to tell Dong-hao whether he can achieve his goal.

Input
There is a number T shows there are T test cases below. ( T <= 50)

For each test case , there are 6 numbers Ai ( 1 <= Ai <= 100 ).

Output
If Dong-hao can achieve his goal , output “Grandpa Shawn is the Winner!”
If he can not , output “What a sad story!”

Sample Input
3
1 2 3 3 2 2
2 2 2 2 2 2
1 2 2 2 3 4

Sample Output
What a sad story!
What a sad story!
Grandpa Shawn is the Winner!
HintFor the first test case , {3 , 1 , 2 , 2 , 2 , 3} Grandpa Shawn can take 6 at most . But Beautiful-leg Mzry can take 6 too. So there is a tie.
For the second test cases , Grandpa Shawn loses.
For the last one , Dong-hao can arrange the numbers as {3 , 2 , 2 , 2 , 1 , 4} , Grandpa Shawn can take 7 , but Beautiful-leg Mzry can take 6 at most. So Grandpa Shawn Wins!

解题思路:这是一道简单的题目,其实大概意思就是:对于任意输入的6个整数,最大的两个最大数之和是否能够大于剩下4个数的任意三个数(take any of 3 numbers from the last(剩下) 4 numbers )之和——–所以要与剩下的最大三个数之和比较

/*
  author : Yangchengfeng
*/

#include<stdio.h>
#define N 6

int main()
{
    int t, num[N];
    while(scanf("%d", &t)!=EOF){
        while(t--){
            int i = 0, j, max, temp, sumG = 0, sumB = 0;
            for(; i<6; i++){
                scanf("%d", &num[i]);
            }
            max = num[0];
            for(i=0; i<6; i++){
                for(j=i; j<6; j++){
                    if(num[j] > num[i]){
                        temp = num[j];
                        num[j] = num[i];
                        num[i] = temp;
                    }
                }
            }
            sumG = num[0] + num[1];
            sumB = num[2] + num[3] + num[4];
            if(sumG > sumB){
                printf("Grandpa Shawn is the Winner!\n");
            } else {
                printf("What a sad story!\n");
            }
        }
    }
    return 0;
}

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值