Dark roads 2988

32 篇文章 1 订阅
31 篇文章 0 订阅

Dark roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 811    Accepted Submission(s): 335


Problem Description
Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?

 

Input
The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 2 31.
 

Output
For each test case print one line containing the maximum daily amount the government can save.
 

Sample Input
  
  
7 11 0 1 7 0 3 5 1 2 8 1 3 9 1 4 7 2 4 5 3 4 15 3 5 6 4 5 8 4 6 9 5 6 11 0 0
 

Sample Output
  
  
51
/*简单的最小生成树问题*/
/*
题意::
		政府要修路,先给出城市数n和路的条数m,然后是m条路,以及两条路间的距离
		问政府最多能省多少钱。 
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[200100];
int n,m,sum;
struct zz
{
	int f1,f2,l;
}q[200100];
int cmp(zz x,zz y)
{
	return x.l<y.l;
}
/*int find(int x)//这种超时 
{
	while(x!=a[x])
		x=a[x];
		return x;
}*/
int find (int x)
{
	int r=x;
	while(r!=a[r])
		r=a[r];
	int i=x,j;
	while(i!=r)
	{
		j=a[i];
		a[i]=r;
		i=j;
	}
	return r;
}
int marge(int x,int y,int z)
{
	int fx,fy;
	fx=find(x);fy=find(y);
	if(fx!=fy)
	{
		sum+=z;
		a[fx]=fy;
	}
}
int main(){
	int i,j,num;
	while(scanf("%d%d",&n,&m),n||m)
	{
		num=0;sum=0;
		for(i=0;i<n;i++)
			a[i]=i;
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&q[i].f1,&q[i].f2,&q[i].l);
			num+=q[i].l;
		}
		sort(q,q+m,cmp);
		for(i=0;i<m;i++)
		{
			marge(q[i].f1,q[i].f2,q[i].l);
		}
		printf("%d\n",num-sum);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值