hdoj GCC 3123 (大数阶乘取余&转换)

GCC

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4463    Accepted Submission(s): 1470


Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
 

Sample Input
  
  
1 10 861017
 

Sample Output
  
  
593846
//由题意可知:当n>m时,从m-n这一区域对m取余都得0,所以不用计算。这样就简化了很多。
此题有个坑点就是0!=1;这个必须得注意。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define ll long long
#define N 1000010
using namespace std;
char s[110];
ll sum[N];
ll change(char *s)
{
	int l,i,ans=0;
	l=strlen(s);
	for(i=0;i<l;i++)
		ans=ans*10+(s[i]-'0');
	return ans; 
}
int main()
{
	int t;
	int n,m;
	int i,j,k,l;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%d",s,&m);
		l=strlen(s);
		if(l<7)
		{
			n=change(s);
			if(n>m)
				n=m-1;
			sum[0]=1;
			int ans=0;
			for(i=1;i<=n;i++)
			{
				sum[i]=(sum[i-1]*i)%m;
				ans=(ans+sum[i])%m;
			}
			printf("%d\n",(ans+1)%m);
		}
		else
		{
			n=m-1;
			sum[0]=1;
			int ans=0;
			for(i=1;i<=n;i++)
			{
				sum[i]=(sum[i-1]*i)%m;
				ans=(ans+sum[i])%m;
			}
			printf("%d\n",(ans+1)%m);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值