poj Sumsets 2229 (机智打表)

99 篇文章 0 订阅
85 篇文章 0 订阅
Sumsets
Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 15047 Accepted: 5999

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:  

1) 1+1+1+1+1+1+1  
2) 1+1+1+1+1+2  
3) 1+1+1+2+2  
4) 1+1+1+4  
5) 1+2+2+2  
6) 1+2+4  

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).  

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

//这是一位大神的思路,讲的挺详细的。。。

题意:给出一个整数n,求解该整数n有多少种由2的幂次之和组成的方案.
解题思路:
1.可以将n用二进制表示.
n=1,只有1种表示方法。
n=2,10(2),二进制表示下,可以分拆成{1,1},{10}有两种表示方法
n=3, 11(2),可以分拆成{1,1,1},{10,1}.
n=4, 100(2),{1,1,1,1},{10,1,1},{10,10},{100}.
总结:如果所求的n为奇数,那么所求的分解结果中必含有1,因此,直接将n-1的分拆结果中添加一个1即可 为s[n-1]
如果所求的n为偶数,那么n的分解结果分两种情况
1.含有1 这种情况可以直接在n-1的分解结果中添加一个1即可 s[n-1]
2.不含有1 那么,分解因子的都是偶数,将每个分解的因子都除以2,刚好是n/2的分解结果,并且可以与之一一对应,这种情况有 s[n/2]

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 1000010
using namespace std;
int a[N];
int main()
{
	int n,i;
	a[1]=1;a[2]=2;
	for(i=3;i<N;i++)
	{
		if(i&1)
			a[i]=a[i-1];
		else
		{
			a[i]=a[i-1]+a[i/2];
			a[i]%=1000000000;
		}
	}
	while(scanf("%d",&n)!=EOF)
		printf("%d\n",a[n]);
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值