hdoj Consumer 3449 (背包)好题

Consumer

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 1897    Accepted Submission(s): 1010


Problem Description
FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.

Input
The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)

Output
For each test case, output the maximum value FJ can get

Sample Input
  
  
3 800 300 2 30 50 25 80 600 1 50 130 400 3 40 70 30 40 35 60

Sample Output
  
  
210
/* 题意:每种类型的物品要一个箱子中,并且每个箱子都得花钱买,问最终卖得的物品的最大价值。 给你两个数 n,w,n表示有n中类型的物品,w表示总钱数。 接下来有n行,每行先输入两个数ww(箱子的价格),t(此箱中放的物品数),     接着输入t对数,每对数有c(表示物品的价格),v(表示物品的价值) */
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define ll long long
#define N 100010
using namespace std;
ll dp[N];
ll a[N];
int main()
{
	int n,w;
	int ww,t;
	int i,j,k; 
	while(scanf("%d%d",&n,&w)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&ww,&t);
			for(j=0;j+ww<=w;j++)
				a[j+ww]=dp[j];
			for(j=1;j<=t;j++)
			{
				int c,v;
				scanf("%d%d",&c,&v);
				for(k=w;k>=c+ww;k--)
					a[k]=max(a[k],a[k-c]+v);
			}
			for(j=ww;j<=w;j++)
				dp[j]=max(dp[j],a[j]);
		}
		printf("%lld\n",dp[w]);
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值