hdoj Rikka with Graph 5631 (并查集)

85 篇文章 0 订阅
32 篇文章 1 订阅

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 651    Accepted Submission(s): 295


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number   T(T30) ——The number of the testcases.

For each testcase, the first line contains a number   n(n100) .

Then n+1 lines follow. Each line contains two numbers   u,v  , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
问题描述
众所周知,萌萌哒六花不擅长数学,所以勇太给了她一些数学问题做练习,其中有一道是这样的:

给出一张 nn 个点 n+1n+1 条边的无向图,你可以选择一些边(至少一条)删除。

现在勇太想知道有多少种方案使得删除之后图依然联通。

当然,这个问题对于萌萌哒六花来说实在是太难了,你可以帮帮她吗?
输入描述
第一行一个整数表示数据组数 T(T \leq 30)T(T30)。

每组数据的第一行是一个整数 n(n \leq 100)n(n100)。

接下来 n+1n+1 行每行两个整数 u,vu,v 表示图中的一条边。
输出描述
对每组数据输出一行一个整数表示答案。
输入样例
1
3
1 2
2 3
3 1
1 3
输出样例
9
//思路:
要使n个点连通,要n-1条边
因为给出了n个点,n+1条边,所以最多可以删2条边。
先给给出的边一个编号,对编好号的边进行判断,如果能连通就将方案数加1.
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define ll long long
using namespace std;
int a[110];
int n;
struct zz
{
	int s;
	int e;
}p[110];
int find(int x)
{
	while(a[x]!=x)
		x=a[x];
	return x;
}
int judge(int x,int y)
{
	int i,j;
	for(i=1;i<=n;i++)
		a[i]=i;
	for(i=0;i<=n;i++)
	{
		if(i==x||i==y)
			continue;
		int fx=find(p[i].s);
		int fy=find(p[i].e);
		if(fx!=fy)
			a[fy]=fx;
	}
	int cnt=0;
	for(i=1;i<=n;i++)
		if(a[i]==i)
			cnt++;
	return cnt==1?1:0;
}
int main()
{
	int t,i,j,k;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<=n;i++)//每条边一个编号。 
			scanf("%d%d",&p[i].s,&p[i].e);		
		int ans=0;
		for(i=0;i<=n;i++)
		{
			for(j=i;j<=n;j++)
			{
				if(judge(i,j))//删除的一条或两条边的编号。 
					ans++;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值