田忌赛马后传 &nyoj 田忌赛马 364 (贪心)

27 篇文章 0 订阅

田忌赛马后传

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 1045   Accepted Submission(s) : 164
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

田忌赛马相信大家都很熟悉了。。。齐王在吃过亏后洗心革面,努力钻研ACM,终于成为算法大神。他决定再次向田忌挑战,但同时他又很欣赏田忌,让他有赢的机会,于是改变了下规则:齐王和田忌各拥有n匹马,每匹马有一个速度值,快的马总是能战胜慢的马,当两匹马速度相同时为平局,现在,齐王规定每赢一场(即双方各挑出一只马决斗,用过的马不可再用)可以获得100金币,齐王要求田忌能过获得最多的金币。
田忌听到后吓的不行,TMD我只会3只马的情况,多了我脑子不够用,于是求助也是算法大神的你,你能帮他解决吗?

Input

有多组测试数据。第一行为齐王和田忌各自马的数量n(n<1000),接下来两行分别有n个整数,分别为田忌和齐王的马的速度v(v<10000)

Output

对于每组数据,输出一行表示田忌能够获得的最多的金币数。

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20

Sample Output

100
0
 
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define IN __int64
#define ull unsigned long long
#define ll long long
#define N 1010
#define M 1000000007
using namespace std;
int a[N],b[N];
int main()
{
	int n,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		int nn=n;
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		sort(a,a+n);sort(b,b+n);
		n--;
		int m=n;
		i=0;j=0;
		int y=0,s=0;
		while(i<=n&&j<=m)
		{
			if(a[i]>b[j])
			{
				i++;j++;y++;
			}
			else if(a[i]==b[j])
			{
				if(a[n]>b[m])
				{
					n--;m--;y++;
				}
				else if(a[n]==b[m])
				{
					if(a[i]<b[m])
					{
						i++;m--;s++;
					}
					else if(a[i]==b[m])
						break;
				}
				else
				{
					i++;m--;s++;
				}
			}
			else
			{
				i++;m--;s++; 
			}
		}
		printf("%d\n",(y-s)*100);
	}
	return 0;
} 

田忌赛马

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
输入
The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
样例输出
200
0
0
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define IN __int64
#define ull unsigned long long
#define ll long long
#define N 1010
#define M 1000000007
using namespace std;
int a[N],b[N];
int main()
{
	int n,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		int nn=n;
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		sort(a,a+n);sort(b,b+n);
		n--;
		int m=n;
		i=0;j=0;
		int y=0,s=0;
		while(i<=n&&j<=m)
		{
			if(a[i]>b[j])
			{
				i++;j++;y++;
			}
			else if(a[i]==b[j])
			{
				if(a[n]>b[m])
				{
					n--;m--;y++;
				}
				else if(a[n]==b[m])
				{
					if(a[i]<b[m])
					{
						i++;m--;s++;
					}
					else if(a[i]==b[m])
						break;
				}
				else
				{
					i++;m--;s++;
				}
			}
			else
			{
				i++;m--;s++; 
			}
		}
		printf("%d\n",(y-s)*200);
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值