HDU - 5479 Scaena Felix (栈模拟)水

133 篇文章 0 订阅
9 篇文章 0 订阅
HDU - 5479
Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

 Status

Description

Given a parentheses sequence consist of '(' and ')', a modify can filp a parentheses, changing '(' to ')' or ')' to '('.  

If we want every not empty <b>substring</b> of this parentheses sequence not to be "paren-matching", how many times at least to modify this parentheses sequence?  

For example, "()","(())","()()" are "paren-matching" strings, but "((", ")(", "((()" are not.
 

Input

The first line of the input is a integer   , meaning that there are    test cases.  

Every test cases contains a parentheses sequence    only consists of '(' and ')'.  

.
 

Output

For every test case output the least number of modification.
 

Sample Input

        
        
3 () (((( (())
 

Sample Output

        
        
1 0 2
 

Source

BestCoder Round #57 (div.2)
//题意:
给你一串字符串,问有几对括号
直接栈模拟就行了
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#define INF 0x3f3f3f3f
#define ull unsigned lonb long
#define ll long long
#define IN __int64
#define N 1010
#define M 1000000007
using namespace std;
stack<char>ss;
char s[N];
int main()
{
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",s);
		int len=strlen(s);
		int l=0,r=0;
		for(i=0;i<len;i++)
		{
			if(s[i]=='(')
			{
				l++;
				ss.push(s[i]);
			}
			else
			{
				if(l)
				{
					r++;l--;
					ss.pop();
				}
			}	
		}
		printf("%d\n",r);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值