The Lucky Week

Edward, the headmaster of the Marjar University, is very busy every day and always forgets the date.
There was one day Edward suddenly found that if Monday was the 1st, 11th or 21st day of that month, he could remember the date clearly in that week. Therefore, he called such week “The Lucky Week”.
But now Edward only remembers the date of his first Lucky Week because of the age-related memory loss, and he wants to know the date of the N-th Lucky Week. Can you help him?

Input
There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:
The only line contains four integers Y, M, D and N (1 ≤ N ≤ 109) indicating the date (Y: year, M: month, D: day) of the Monday of the first Lucky Week and the Edward’s query N.
The Monday of the first Lucky Week is between 1st Jan, 1753 and 31st Dec, 9999 (inclusive).
Output
For each case, print the date of the Monday of the N-th Lucky Week.
样例输入
2
2016 4 11 2
2016 1 11 10
样例输出
2016 7 11
2017 9 11

题意:如每个月的1号,11号,21号是星期一,呢么他是幸运周

思路:因为有闰年和平年之分,所以判断一下就好,然后就每次+7,加一周都是星期一,所以不必考虑,主要就是循环次数太大,不找到循环规律就会超时,理解400年一循环,就能简单的找到规律

错误代码:这样写会超时

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int num[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int numx[13]={0,31,29,31,30,31,30,31,31,30,31,30,31};

bool run(int year)
{
    if(year%400==0||(year%4==0&&year%100!=0))
        return true;
    else
        return false;

}

    int main ()
    {
        int y,m,d,q;
        int T;scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d%d%d",&y,&m,&d,&q);
    
            while(q){
                if(d==11||d==21||d==1)
                    q--;
                if(q==0)
                    break;
                if(run(y))
                {
                    d+=7;
                    if(d>numx[m])
                    {
                        d-=numx[m];
                        m++;
                    }
                    if(m>12){
                        y++;
                        m=1;
                    }
                }
                else {
                    d+=7;
                    if(d>num[m])
                    {
                        d-=num[m];
                        m++;
                    }
                    if(m>12){
                        y++;
                        m=1;
                    }
                }
            }
            printf("%d %d %d\n",y,m,d);
        }
        return 0;
    }

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int num[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int numx[13]={0,31,29,31,30,31,30,31,31,30,31,30,31};

bool run(int year)
{
    if(year%400==0||(year%4==0&&year%100!=0))
        return true;
    else
        return false;

}

int main ()
{
    int y,m,d,q;
    int t;scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&y,&m,&d,&q);
        y+=(q/2058)*400;//由于没四百年一个循环日期,所以找到四百年里有多少个幸运日就好
        q%=2058;//由于循环,这里取余操作,减少循环次数,会防止超时

        while(q){
            if(d==11||d==21||d==1)
                q--;
            if(q==0)
                break;
            if(run(y))
            {
                d+=7;
                if(d>numx[m])
                {
                    d-=numx[m];
                    m++;
                }
                if(m>12){
                    y++;
                    m=1;
                }
            }
            else {
                d+=7;
                if(d>num[m])
                {
                    d-=num[m];
                    m++;
                }
                if(m>12){
                    y++;
                    m=1;
                }
            }
        }
        printf("%d %d %d\n",y,m,d);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值