HDU 1016 Prime Ring Problem(深搜)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32872    Accepted Submission(s): 14544


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1312  1072  1242  1175  1253 





     题意:要求1-n之间的所有数组成一个圆环,而且要求相邻的两个数相加的和是素数。
    思路:因为n的数据范围只是1-20,所以相加的和最大不会超过40,所以把40以内的素数标记出来。然后DFS深搜,符合题意的直接输出就可以了。


代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>

using namespace std;

int pv[50];
int n;
int p[50];
int v[50];

void getprime()
{
    for(int i=1;i<50;i++)
    {
        pv[i] = 1;
    }
    for(int i=1;i<=41;i++)
    {
       int pi = sqrt(i);
       for(int j=2;j<=pi;j++)
       {
           if(i%j == 0)
           {
               pv[i] = 0;
               break;
           }
       }
    }
}

void DFS(int cnt,int x)
{
    if(cnt == n && pv[p[n-1]+p[0]] == 1)
    {
        for(int i=0;i<n;i++)
        {
            if(i == 0)
            {
                printf("%d",p[i]);
            }
            else
            {
                printf(" %d",p[i]);
            }
        }
        printf("\n");
        return ;
    }
    for(int i=2;i<=n;i++)
    {
        if(pv[i+x] == 1 && v[i] == 0)
        {
            p[cnt] = i;
            v[i] = 1;
            DFS(cnt+1,i);
            v[i] = 0;
        }
    }
}

int main()
{
    getprime();
    int k = 0;
    while(scanf("%d",&n)!=EOF)
    {
        memset(v,0,sizeof(v));
        printf("Case %d:\n",++k);
        p[0] = 1;
        v[1] = 1;
        DFS(1,1);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值