POJ 2442 Sequence(堆的应用)

Sequence
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 8269 Accepted: 2705

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

Source

POJ Monthly,Guang Lin



    题意:有一个n*m的矩阵,要求在每一行中选取一个元素,求完n行后会得到一个和,然后题目要求输出前m小的和。




#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int sum[2001],num[2001],q[2001];
int n,m;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(sum,0,sizeof(sum));
        for(int i=0;i<m;i++)
        {
            scanf("%d",&sum[i]);
        }
        for(int i=1;i<n;i++)
        {
            memset(num,0,sizeof(num));
            sort(sum,sum+m);
            for(int j=0;j<m;j++)
            {
                scanf("%d",&num[j]);
            }
            sort(num,num+m);
            for(int j=0;j<m;j++)
            {
                q[j] = sum[0] + num[j];
            }
            make_heap(q,q+m);   ///根据已有的元素进行建堆
            printf("qian = %d    zui =   %d\n",q[0],q[m-1]);
            for(int j=1;j<m;j++)
            {
                for(int k=0;k<m;k++)
                {
                    int cnt = sum[j] + num[k];
                    if(cnt>=q[0])
                    {
                        break;
                    }
                    pop_heap(q,q+m);    ///取走根节点
                    q[m-1] = cnt;
                    printf("m-1 = %d\n",q[m-1]);
                    push_heap(q,q+m);   ///向堆中添加一个节点,并使之满足大顶堆的特性
                }
            }
            for(int j=0;j<m;j++)
            {
                sum[j] = q[j];
            }
        }
        sort(sum,sum+m);
        for(int i=0;i<m-1;i++)
        {
            printf("%d ",sum[i]);
        }
        printf("%d\n",sum[m-1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值