poj 2418 Hardwood Species

Hardwood Species
Time Limit: 10000MS
Memory Limit: 65536K
Total Submissions: 20931
Accepted: 8208

Description
Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.
America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input
Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Output
Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483

Yellow Birch 3.4483


题目链接


解题思路: 本题有两种解法,分别使用map和字典序做本题。

法一:map

使用map让本题中的每一种树对应一个int值,在输入过程中,如果前面没有这种树,就创建一个新值,即map[str] = 1,如果有这种树,就在原有基础上加1,即map[str]++;输入结束后使用sort对其进行排序,再依次输出。这种方法简单,运行内存低,但时间复杂度高,达到3141ms.

代码如下:

#include <iostream>
#include <string>
#include <cstdio>
#include <algorithm>
#include <map>

using namespace std;

const int maxn = 1000010;

string str,name[10010];
int ans=0,tot=0;
map<string,int> tree;

int main()
{
      while(getline(cin,str) && str!="")
      {
            if(tree.find(str) == tree.end())
            {
                  tree[str] = 1;
                  name[ans++] = str;
            }
            else
                  tree[str]++;
            tot++;
      }
      sort(name,name+ans);
      for(int i=0;i<ans;i++)
      {
            printf("%s %.4lf\n",name[i].c_str(),tree[name[i]]*1.0/tot*100);
      }
      return 0;
}

法二:字典序

本题也可用字典序外加深搜解决,首先在输入过程中建树,输入结束后,在使用dfs按照字典序对其进行深搜,终止条件是如果p->cnt不等于0就输出。

代码如下:


<span style="font-size:14px;">#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

struct node{    //建立节点
      int cnt;
      node *next[130];
      node()
      {
            cnt = 0;
            memset(next,0,sizeof(next));
      }
};

int n;
node *root = NULL;

void buildtrie(char *s)//建树
{
      node *tmp = NULL;
      node *p = root;
      int l = strlen(s);
      for(int i=0;i<l;i++)
      {
            if(p->next[s[i]] == NULL)
            {
                  tmp = new node;
                  p->next[s[i]] = tmp;
            }
            p = p->next[s[i]];
      }
      p->cnt++;//每个单词末尾cnt都不为0
}

void dfs(node *root)
{
      static char word[35];
      static int pos;
      int i;
      if(root->cnt)//终止条件,如果找到尾巴就输出
      {
            word[pos] = '\0';
                  printf("%s %.4lf\n",word,root->cnt*100.0/n);
            return;
      }
      for(int i=0;i<130;i++)//按照字典序从头开始遍历
      {
            if(root->next[i])
            {
                  word[pos++] = i;
                  dfs(root->next[i]);
                  pos--;
            }
      }
}

int main()
{
      char str[35];
      n = 0;
      root = new node;
      while(gets(str) && strcmp(str,"") != 0)
      {
            buildtrie(str);
            n++;
      }
      dfs(root);
      return 0;
}
</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值