Semi-prime H-numbers POJ - 3292

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input
21 
85
789
0
Sample Output
21 0
85 5
789 62

题目大意:

定义一种数叫H-numbers,它是所有能除以四余一的数。

H-numbers中分三种数:

1、H-primes,这种数只能被1和它本身整除,不能被其他的H-number整除,例如9是一个H-number,能被1,3,9整除,但3不是H-number,所以他是H-primes。

2、H-semi-primes是由两个H-primes相乘得出的。

3、剩下的是H-composite。


问给一个数,求1到这个数之间有多少个H-semi-primes。

本题目刚开始我的想法时先判断得到一个数,先判断是否是H_prime,在判断是否能让两个H_prime相乘,后来TLE,看了题解之后,才知道

1.当在题目解答前每个数是确定的,且环环相扣,那么便不必挨个判断,用数组存放好直接提取

2.本题巧妙的省略了判断是否是质数的过程,根据辗转相除求最小公倍数的方法,那就是如果最小公约数时1,也就是为H_prime数时,两者的最小公倍数就是两者直接相×,若还有其他因子,那么一定不是质数,减少了循环次数



#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#define MAX 1000100
using namespace std;

int H_semi_prime[MAX],sum[MAX];

void solve()
{
    memset(H_semi_prime,0,sizeof(H_semi_prime));
    int ans=0;
    for(int i=5;i<=MAX;i=i+4)
    {
        for(int j=5;j<=MAX;j=j+4)
        {
            if(i*j>MAX)
                break;
            if(H_semi_prime[i]==0&&H_semi_prime[j]==0)
            {
                H_semi_prime[i*j]=1;
            }
            else
            {
                H_semi_prime[i*j]=-1;
            }
        }
    }
    for(int i=1;i<=MAX;i++)
    {
        if(H_semi_prime[i]==1)
        {
            ans++;
        }
        sum[i]=ans;
    }
}

int main()
{
    int p;
    solve();
    while(~scanf("%d",&p))
    {
        if(p==0)
            break;
        printf("%d %d\n",p,sum[p]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值