POJ3292Semi-prime H-numbers(筛选法)


Semi-prime H-numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8250 Accepted: 3569

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 ×h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

题目大意:

定义一种数叫H-numbers,它是所有能除以四余一的数。

H-numbers中分三种数:

H-primes: 这种数只能被1和它本身整除,不能被其他的H-number整除,例如9是一个H-number,能被1,3,9整除,但3不是H-number,所以他是H-primes。

H-semi-primes是由两个H-primes相乘得出的。

剩下的是H-composite。

问给一个数,求1到这个数之间有多少个H-semi-primes。

筛选法,好题

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;
const int MAX = 1000000 + 5;
int a[MAX],cnt[MAX];
int main()
{
    memset(a,0,sizeof(a));
    memset(cnt,0,sizeof(cnt));
    for(int i = 5; i < MAX; i+=4)
    {
        for(int j = 5; i * j < MAX; j+=4)
        {
            if(a[i] == 0 && a[j] == 0)//都没筛选掉,所以他们的乘积可以
            {
                a[i * j] = 1;
            }
            else
                a[i * j] = -1;
        }
    }
    int k = 0;
    for(int i = 1; i < MAX; i ++)
    {
        if(a[i] == 1)
            k++;
        cnt[i] = k;
    }
    int n;
    while(scanf("%d", &n) != EOF && n)
    {
        printf("%d %d\n",n,cnt[n]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值