POJ 3616 Milking Time(DP,区间和最大)

Milking Time
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 9937
Accepted: 4124

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

题目大意:
       farmer John 要给女主牛 挤奶了。挤奶时间 N (1 ≤ N ≤ 1,000,000) hours,注意Bessie进了一间黑心企业,每次挤奶休息完R (1 ≤ R ≤ N)hours后,又可以挤。然后farmer John 有M个时间段,开始时间s,结束时间e,一旦开始就不能停下,直到挤完奶。在这些时间段里可以给Bessie挤奶,但每个时间段的效率不同,有个挤得多一点,有得少一点。现在你的任务是根据famer john的时间段,选择搭配起来最有效率的时间段来让Bessie产奶最多。
这就是一道区域的最大求和问题。

区域的最大求和
    给定一个大的区间,里面有相交的区域,每个区域都代表了一个值,求取得的区域和最大。
模版代码
#define MAXN //区间数 
struct node{
	int s;//区域开始的下标 
	int e;//区域结束的下标 
	int w;//区域代表的值 
}a[MAXN];
int dp[MAXN];
int main(){
	sort(a,a+m);//按开始的下标排序 
	int ans=0;
	for(int i=0;i<m;i++){
		dp[i]=a[i].w;
		for(int j=0;j<i;j++){
			if(a[i].s>=a[j].e)
			dp[i]=max(dp[i],dp[j]+a[i].w);
			ans=max(ans,dp[i]);
		}
	}
}
在这题中,只需要把每次挤奶结束的时间加上休息的时间就是最终结束的时间
AC代码
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct node{
	int s,e,w;
}a[1005];
int dp[1005];
bool cmp(node a,node b){
	if(a.s<b.s)return true;
	if(a.s==b.s&&a.e<b.e)return true;
	return false;
}
int main(){
	int n,m,r;
	scanf("%d%d%d",&n,&m,&r);
	for(int i=0;i<m;i++){
		scanf("%d%d%d",&a[i].s,&a[i].e,&a[i].w);
		a[i].e+=r;
	}
	sort(a,a+m,cmp);
	int ans=0;
	for(int i=0;i<m;i++){
		dp[i]=a[i].w;
		for(int j=0;j<i;j++){
			if(a[i].s>=a[j].e)
			dp[i]=max(dp[i],dp[j]+a[i].w);
			ans=max(ans,dp[i]);
		}
	}
	printf("%d\n",ans);
	return 0;
}



  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值