2017杭电多校第六场 1003 Inversion(暴力)HDU 6098

Inversion

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 8    Accepted Submission(s): 6


Problem Description
Give an array A, the index starts from 1.
Now we want to know  Bi=maxijAj  ,  i2 .
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer n : the size of array A.
Next one line contains n integers, separated by space, ith number is  Ai .

Limits
T20
2n100000
1Ai1000000000
n700000
 

Output
For each test case output one line contains n-1 integers, separated by space, ith number is  Bi+1 .
 

Sample Input
  
  
2 4 1 2 3 4 4 1 4 2 3
 

Sample Output
  
  
3 4 3 2 4 4
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6107  6106  6105  6104  6103 

就纯暴力吧。。
#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
#define ll long long
struct node{
    int no;
    ll num;
    bool friend operator < (node x, node y)
    {
        return x.num<y.num;
    }
}a[100005];
int main()
{
    int T,n,i,j;
    ll k;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        for(i=1;i<=n;i++) {
        scanf("%lld",&k);    
        a[i].no=i; a[i].num=k;
        }
        sort(a+1,a+n+1);
        for(i=2;i<=n;i++)
          {
              for(j=n;j>=0;j--)
                {
                    if(a[j].no%i!=0) 
                    {
                        printf("%d",a[j].num);
                        break;
                    }
                }
                if(i!=n) printf(" ");
          }
          printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值