poj 1094 Sorting It All Out (拓扑排序)@

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 
Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.


给N个A小于B的关系式,依次判断这些关系是否冲突;


#include <iostream>
#include <cstdio>
#include <cstring>
#include <climits>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
const int N = 210;
vector<int>p[N];
char str[1100][5];
int in[N], out[N], in1[N], out1[N], vis[N], w[N];


int tupo(int n)
{
    int cnt=0, flag=0, num=0;
    queue<int>q;
    for(int i=1;i<=n;i++)
    {
        if(in1[i]==0&&out[i]==0) continue;
        if(in1[i]!=0||out1[i]!=0) num++;
        if(in1[i]==0) q.push(i);
    }
    if(q.empty()) return -1;
    memset(vis,0,sizeof(vis));
    while(!q.empty())
    {
        if(q.size()>1) flag=1;
        int u=q.front();q.pop();
        w[++cnt]=u;
        vis[u]=1;
        for(int i=0;i<p[u].size();i++)
        {
            int v=p[u][i];
            if(vis[v]) return -1;
            in1[v]--;
            if(in1[v]==0) q.push(v);
        }
    }
    if(cnt==n&&flag!=1) return 1;
    if(cnt!=num) return -1;
    return 0;
}


int main()
{
    int n, m;
    while(scanf("%d %d", &n, &m),m||n)
    {
        for(int i=0;i<=n;i++) p[i].clear();
        char a, b;
        for(int i=0;i<m;i++)
        {
            scanf(" %c<%c",&a,&b);
            str[i][1]=a, str[i][2]=b;
        }
        int flag=0;
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        for(int i=0;i<m;i++)
        {
            a=str[i][1], b=str[i][2];
            int u=(a-'A')+1, v=(b-'A')+1;
            p[u].push_back(v);
            out[u]++, in[v]++;
            memcpy(in1,in,sizeof(in));
            memcpy(out1,out,sizeof(out));
            int tmp=tupo(n);
            if(tmp==-1)
            {
                flag=1;
                printf("Inconsistency found after %d relations.\n",i+1);
                break;
            }
            if(tmp==1)
            {
                flag=1;
                printf("Sorted sequence determined after %d relations: ",i+1);
                for(int j=1;j<=n;j++)
                    printf("%c",w[j]-1+'A');
                printf(".\n");
                break;
            }
        }
        if(flag==0)
            printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值