字符串-POJ3974-Palindrome

Palindrome

Time Limit: 15000MS Memory Limit: 65536K

Description

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, “Can you propose an efficient algorithm to find the length of the largest palindrome in a string?”

A string is said to be a palindrome if it reads the same both forwards and backwards, for example “madam” is a palindrome while “acm” is not.

The students recognized that this is a classical problem but couldn’t come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said “Okay, I’ve a better algorithm” and before he starts to explain his idea he stopped for a moment and then said “Well, I’ve an even better algorithm!”.

If you think you know Andy’s final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.

Input

Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string “END” (quotes for clarity).
Output

For each test case in the input print the test case number and the length of the largest palindrome.

Sample Input

abcbabcbabcba
abacacbaaaab
END

Sample Output

Case 1: 13
Case 2: 6


解题心得:

  1. 就是叫你去求一个字符串中的最长回文串,暴力肯定是会超时的,可以去看看manacher算法,这个算法不是很难。manacher详解。这就是一个manacher算法的模板题,看懂了就会做了。

#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 1e6+100;
char s[maxn<<1],ch[maxn<<1];
int rl[maxn<<1];
int get_ch(int len)
{
    int ch_len = 0;
    for(int i=0; i<len; i++)
    {
        ch[ch_len++] = '#';
        ch[ch_len++] = s[i];
    }
    ch[ch_len++] = '#';//注意要把最后一个#给加上去
    return ch_len;
}

int manacher(int ch_len)
{
    int max_right = 0,pos = 0,Max = 0;;
    for(int i=0;i<ch_len;i++)
    {
        rl[i] = 1;
        if(i < max_right)
            rl[i] = min(rl[(pos<<1)-i],max_right-i);
        while(i+rl[i]<ch_len && i-rl[i]>=0 && ch[i+rl[i]] == ch[i-rl[i]])
            rl[i]++;
        //max_right、pos更新
        if(i + rl[i]-1 > max_right)
        {
            max_right = i+rl[i]-1;
            pos = i;
        }
        //记录最大的那一个回文串
        if(rl[i] > Max)
            Max = rl[i];
    }
    return Max-1;//记得要减去1
}

int main()
{
    int t = 1;
    while(scanf("%s",s) != EOF)
    {
        if(s[0] == 'E' && s[1] == 'N' && s[2] == 'D' && strlen(s) == 3)
            break;
        int len = strlen(s);
        int len_ch = get_ch(len);//将元字符串改写
        int ans = manacher(len_ch);
        printf("Case %d: %d\n",t++,ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值