HDU:2846-Repository

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=2846
Repository
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)

Problem Description

When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.

Input

There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it’s length isn’t beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.

Output

For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.

Sample Input

20
ad
ae
af
ag
ah
ai
aj
ak
al
ads
add
ade
adf
adg
adh
adi
adj
adk
adl
aes
5
b
a
d
ad
s

Sample Output

0
20
11
11
2


解题心得:

  1. 都知道字典树就是用来查前缀的,但是这个题它询问的字符串在多少个前面给出的字符串中出现过,不仅仅是在前缀中,刚开始使用KMP怼了一波,TLE,然后还是字典树,思想很暴力也很朴实,用给出的串的每一个后缀来建树
    • 例如其中一个串是abbbc,那么在建树的时候要将abbbc,bbbc,bbc,bc,c分别插入树中,但是为了防止一个串被重复计算,例如abab,要将字符串插入的时候做好标记,如果是一个串那么就不用重复加了。
  2. HDU上提交的时候交C++,G++会MLE,黑人问号。

#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 1e5+100;
struct trie
{
    int sum,num;
    trie *child[26];
    trie()
    {
        sum = num = 0;
        for(int i=0;i<26;i++)
            child[i] = NULL;
    }
};
trie *newnode,*current;
trie *root = new trie;
char s[30];

void insert_tree(int p,int num)//第num个串从第p个字符开始的后缀建树
{
    int len = strlen(s);
    current = root;
    for(int i=p;i<len;i++)
    {
        int k = s[i] - 'a';
        if(current->child[k] == NULL)
        {
            newnode = new trie;
            newnode->sum = 1;
            newnode->num = num;
            current->child[k] = newnode;
            current = newnode;
        }
        else
        {
            current = current->child[k];
            if(current->num != num)//如果标记相同说明是同一个串分开的,就不用再加了
            {
                current->num = num;
                (current->sum)++;
            }
        }
    }
}

int query()
{
    current = root;
    int len = strlen(s);
    for(int i=0;i<len;i++)
    {
        int k = s[i] - 'a';
        if(current->child[k] == NULL)
            return 0;
        current = current->child[k];
    }
    return current->sum;
}

int main()
{
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%s",s);
        int len = strlen(s);
        for(int j=0;j<len;j++)
            insert_tree(j,i);
    }
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",s);
        int ans = query();
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值