1003 Max Sum(水题)

Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

虽然是道水题…..但刚看题还以为用线段树做….想了想线段树…..后来发现什么鬼啊,直接从头遍历一遍,如果遇到这个时候的总和小于0就将此节点更新为起点,如果这个时候的总和大于遍历过的值的最大和,就将max更新为sum,然后把这个点设为结束点,注意的是刚开始不能把max设为0,因为更新的最大值可能为负值
AC代码:

#include<bits/stdc++.h>
using namespace std;
const int INF=0x3f3f3f3f;
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    int T,temp,n;
    cin>>T;
    for(int k=1;k<=T;k++) {
        cin>>n;
        int max=-INF,sum=0;
        int start=1,end=1,start_t=1;
        for(int i=1;i<=n;i++) {
            cin>>temp;
            sum+=temp;
            if(sum>max) {
                max=sum;
                end=i;
                start=start_t;
            }
            if(sum<0) {
                sum=0;
                start_t=i+1;
            }
        }
        if(k!=1) cout<<endl;
        cout<<"Case "<<k<<":"<<endl;
        cout<<max<<" "<<start<<" "<<end<<endl;
    }
    return 0;
}

四级考完….该好好准备期末和刷题了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值