The sum problem
Problem Description
Given a sequence 1,2,3,……N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
Sample Input
20 10
50 30
0 0
Sample Output
[1,4]
[10,10]
[4,8]
[6,9]
[9,11]
[30,30]
题目大意是问从1到n有多少个连续区间使和为m
这道题从Sn=n*(a1+an)/2入手,Sn=a1 n+n (n-1)/2,为了使n最大,所以a1=1,所以n=sqrt(2 * m),这时我们确定了长度上界为sqrt(2 * m),而Sn=a1 n+n (n-1)/2,a1=(Sn-n *(n-1)/2)/n,所以范围就是[a1+1,a1+n]
#include<bits/stdc++.h>
using namespace std;
using LL = int64_t;
const int INF = 0x3f3f3f3f;
const int mod=1e9+7;
int main()
{
LL n,m;
while(~scanf("%lld%lld",&n,&m)&&(n||m)) {
for(int i=sqrt(2*m);i>=1;i--) {
LL b=(m-i*(i+1)/2);
if(b%i==0)
printf("[%lld,%lld]\n",b/i+1,b/i+i);
}
printf("\n");
}
return 0;
}