最大子阵和(DP)&& Hdu 1003 && Hdu 1081

我们看最大子阵和之前先看一个最长子序列的问题,给你一个数组,让你求出值最大的连续序列

Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

#include<bits/stdc++.h>
using namespace std;
const int INF=0x3f3f3f3f;
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    int T,temp,n;
    cin>>T;
    for(int k=1;k<=T;k++) {
        cin>>n;
        int max=-INF,sum=0;
        int start=1,end=1,start_t=1;
        for(int i=1;i<=n;i++) {
            cin>>temp;
            sum+=temp;
            if(sum>max) {
                max=sum;
                end=i;
                start=start_t;
            }
            if(sum<0) {
                sum=0;
                start_t=i+1;
            }
        }
        if(k!=1) cout<<endl;
        cout<<"Case "<<k<<":"<<endl;
        cout<<max<<" "<<start<<" "<<end<<endl;
    }
    return 0;
}

这道题就是线性扫一遍,然后从头开始,一直加,当我的sum大于max的时候就把信息赋给max,这个思想算是最大子阵和的一个基础,然后我们来看最大子阵和

To The Max

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

Sample Output
15

这道题我们用先固定起始行,移动终点行,对于每一次移动,用上一道题的最大连续和的方法

#include<bits/stdc++.h>
using namespace std;
using LL=int64_t;
const int INF=0x3f3f3f3f;
int ans[105][105],dp[105];
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    int n;
    while(cin>>n) {
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++) {
                cin>>ans[i][j];
            }
        }
        int sum=-INF;
        for(int i=1;i<=n;i++) {//i是起始行
            memset(dp,0,sizeof(dp));
            for(int j=i;j<=n;j++){//j是终点行
                int temp=0;
                for(int k=1;k<=n;k++){
                    dp[k]+=ans[j][k];//dp[k]的意思是从i到j行的第k列的值
                    if(temp<0) temp=dp[k];
                    else temp+=dp[k];
                    if(temp>sum) sum=temp;
                }
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值