hdu 2639 Bone Collector II 01背包 第k优解

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3338    Accepted Submission(s): 1716


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2 0
 

Author
teddy
 

Source
 

Recommend
teddy   |   We have carefully selected several similar problems for you:   2602  2159  1203  3033  1561 
 

题意:经典01背包+求出给定体积下第k大的价值。


要求出第k大的价值,经典的背包拓展成二维,dp[v][t]表示容量为v的背包能装的第t大的价值。

状态转移类似于一个归并排序。

背包问题的dp其实有两种意义,对应不同的转移。

dp[x]既可以表示容量为x的背包对应的最大价值,(此时初始化均为0)

又可以表示装载了x体积对应的最大价值。(此时dp[0]初始化为0。其余可以为负值了 ,表示达不到。)


状态无法表示-->>加维



#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=100+20;
const int maxV=1000+20;
int n,V,k;
int val[maxn];
int cost[maxn];
int dp[maxV][33],a[33],b[33];
int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&V,&k);
        for(int i=1;i<=n;i++)
        {
           scanf("%d",&val[i]);
        }
        for(int i=1;i<=n;i++)
        {
           scanf("%d",&cost[i]);
        }

        memset(dp,0,sizeof dp);
        for(int i=1;i<=n;i++)
        {
            for(int v=V;v>=cost[i];v--)
            {
                int j;
                for( j=1;j<=k;j++)  a[j]=dp[v-cost[i]][j]+val[i];  a[j]=-1;
                for( j=1;j<=k;j++)   b[j]=dp[v][j];    b[j]=-1;
                int pa,pb,tmp;
                dp[v][0]=-1;
                for( pa=1,pb=1,j=1;j<=k&&a[pa]!=-1&&b[pb]!=-1;)
                {
                    tmp;
                    if(a[pa]>=b[pb])  tmp=a[pa++];
                    else   tmp=b[pb++];
                    if( tmp!= dp[v][j-1] )   dp[v][j++]=tmp;

                }
                if(j==k+1)  continue;
                for(  ;a[pa]!=-1&&j<=k;pa++         ) if(a[pa]!= dp[v][j-1]) dp[v][j++]=a[pa];
                for(  ;b[pb]!=-1&&j<=k;pb++         ) if(b[pb]!= dp[v][j-1]) dp[v][j++]=b[pb];
            }
        }
        printf("%d\n",dp[V][k]);


    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值