hdu 3172 Virtual Friends 带权并查集

我说这题也是坑的不要不要的

输入的格式竟然是这样的:

while(~scanf("%d",&T))

{

   while(T--)

  {

  }

}

Virtual Friends

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7294    Accepted Submission(s): 2097


Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person's network. 

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 

Input
Input file contains multiple test cases. 
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

Sample Input
  
  
1 3 Fred Barney Barney Betty Betty Wilma
 

Sample Output
  
  
2 3 4
 

Source
 



/**==========================================
 *   This is a solution for ACM/ICPC problem
 *
 *   @source:hdu 3172 Virtual Friends
 *   @type:  带权并查集
 *   @author: wust_ysk
 *   @blog:  http://blog.csdn.net/yskyskyer123
 *   @email: 2530094312@qq.com
 *===========================================*/
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<map>
using namespace std;
typedef long long ll;
const int INF =0x3f3f3f3f;
const int maxn= 200000   ;
//const int maxV=12    ;
int pre[maxn+10],a[maxn+10];
map<string ,int >mp;
int n,m;
int find(int x)
{
    return pre[x]==x?x:pre[x]=find(pre[x]);
}
string name1,name2;



void init()
{
    for(int i=0;i<2*m;i++)
        pre[i]=i,a[i]=1;

    mp.clear();
}


int query(string name)
{
    if(mp.count(name))  return mp[name];
    int k=mp.size();
    return mp[name]=k;
}
int main()
{
    int T;
    while(~scanf("%d",&T))  while(T--)
    {
        scanf("%d",&m);
        init();
        for(int i=1;i<=m;i++)
        {
            cin>>name1>>name2;
            int x=query(name1);
            int y=query(name2);
            int rootx=find(x);
            int rooty=find(y);
            if(rootx==rooty)
            {
                printf("%d\n",a[rooty]);
            }
            else
            {
                pre[rootx]=rooty;
                a[rooty]+=a[rootx];
                printf("%d\n",a[rooty]);
            }
        }

    }

   return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值