hdu 4800 Josephina and RPG dp(概率类,较简单)

题意:给定C(m,3)支队伍之间对战获胜的概率表,一开始可以选择任何队伍。

再给定一个序列存放对手队伍的编号,每次获胜之后可以选择和当前战胜的对手换队伍或者不换。

求挑战胜利的最大概率。

解:dp[i][j]表示挑战完前i支队伍,并且当前队伍为j的最大连胜率。

  


Josephina and RPG

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1379    Accepted Submission(s): 412
Special Judge


Problem Description
A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development.
Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part.
The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team gets victory only if they beat all the AI teams.
Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?
 

Input
There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix T whose size is R × R. R equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains N integers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.
 

Output
For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.
 

Sample Input
  
  
4 0.50 0.50 0.20 0.30 0.50 0.50 0.90 0.40 0.80 0.10 0.50 0.60 0.70 0.60 0.40 0.50 3 0 1 2
 

Sample Output
  
  
0.378000
 

Source
 

Recommend
We have carefully selected several similar problems for you:   5717  5716  5715  5714  5713 
 

Statistic |  Submit |  Discuss |  Note




#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define eps (1e-8)
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;

int m,n;
int cb;//角色组合数
double dp[10000+5][120+6];
double win[125][125];
int enemy[10000+5];
void work()
{
    for0(i,cb) dp[0][i]=1;
    for1(i,n)
    {
        int newcb=enemy[i];
        dp[i][newcb]=0;
        for0(j,cb)
        {
            if(j!=newcb) dp[i][j]=dp[i-1][j]*win[j][newcb];//if(j!=newcb) 弄掉了,wa了半天,如果不加判断,那么dp[i][newcb]会被覆盖掉
            dp[i][newcb]=max(dp[i][newcb],dp[i-1][j]*win[j][newcb]);
        }
    }
    double ans=0;
    for0(j,cb) ans=max(ans,dp[n][j]);
    printf("%.6f\n",ans);
}
int main()
{
    while(~scanf("%d",&m))
    {
        cb=m*(m-1)*(m-2)/6;
        for0(i,cb) for0(j,cb)  scanf("%lf",&win[i][j]);
        scanf("%d",&n);
        for1(i,n) scanf("%d",&enemy[i]);
//        cout<<cb<<endl;
        work();
    }

   return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值