HDOJ 题目18651sting(大数 斐波那契)

27 篇文章 0 订阅

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3191    Accepted Submission(s): 1223


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 

Author
z.jt
 

Source
 


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1865

 

ac代码

#include<stdio.h>   
#include<string.h>   
int a[1001][10000];  
char * add(char a[],char b[],char c[])  
{  
    int len1,len2,i,j,t[10000],max,k=0;  
    len1=strlen(a);  
    len2=strlen(b);  
    i=len1-1;  
    j=len2-1;  
	
	memset(t,0,sizeof(t));  
    while(i>=0||j>=0)  
		
    {  
        if(i<0&&j>=0)  
            t[k]+=b[j]-'0';  
        else  
            if(j<0&&i>=0)  
                t[k]+=a[i]-'0';  
            else  
            {  
                t[k]+=a[i]-'0'+b[j]-'0';  
            }  
			k++;  
			t[k]+=t[k-1]/10;  
			t[k-1]%=10;  
			if(t[k])  
				max=k;  
			else  
				max=k-1;  
			i--;  
			j--;  
    }  
    for(i=max;i>=0;i--)  
        c[max-i]=t[i]+'0';  
    c[max+1]='\0';  
    return c;  
}  
void fun()  
{  
    int i;  
    strcpy(a[1],"1");  
    strcpy(a[2],"2");  
    for(i=3;i<=210;i++)  
    {  
        add(a[i-1],a[i-2],a[i]);  
    }  
}  
int main()  
{  
    int n;  
    fun();  
    scanf("%d",&n);  
    while(n--)  
    {  
        int num;
		char s[210];
		scanf("%s",s);
		num=strlen(s);
        printf("%s\n",a[num]);  
    }  
}  


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值