POJ 题目2406 Power Strings(KMP)

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 33655 Accepted: 13983

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

ac代码
#include<stdio.h>
#include<string.h>
__int64 a[1010][110],b[1010][110],inf=1;
int main()
{
	int n,k,i;
	for(i=0;i<18;i++)
		inf*=10;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		int i,j;
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=0;i<=k;i++)
			a[0][i]=1;
		for(j=1;j<=k;j++)
		{
			for(i=1;i<=n;i++)
			{
				if(i<j)
				{
					a[i][j]=a[i][j-1];
					b[i][j]=b[i][j-1];
				}
				else
				{
					a[i][j]=(a[i-j][j]+a[i][j-1])%inf;
					b[i][j]=b[i-j][j]+b[i][j-1]+(a[i-j][j]+a[i][j-1])/inf;
				}
			}
		}
		if(b[n][k])
			printf("%I64d",b[n][k]);
		printf("%I64d\n",a[n][k]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值