POJ 题目2442 Sequence(技巧,优先队列)

25 篇文章 2 订阅
Sequence
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 7687 Accepted: 2540

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

Source

POJ Monthly,Guang Lin
ac代码
#include<stdio.h>
#include<queue>
#include<string.h>
#include<string>
#include<iostream>
using namespace std;
int a[100100];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m,i,j;
		scanf("%d%d",&n,&m);
		priority_queue<int,vector<int>,greater<int> >p;
		priority_queue<int,vector<int>,less<int> >q;
		for(i=0;i<m;i++)
		{
			int x;
			scanf("%d",&x);
			p.push(x);
		}
		for(i=1;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				scanf("%d",&a[j]);
			}
			while(!p.empty())
			{
				int sum=p.top();
				p.pop();
				for(j=0;j<m;j++)
				{
					if(q.size()==m)
					{
						if(sum+a[j]<q.top())
						{
							q.pop();
							q.push(sum+a[j]);
						}	
					}
					else
					{
						if(q.size()<m)
							q.push(sum+a[j]);
					}
				}
			}
			while(!q.empty())
			{
				p.push(q.top());
				q.pop();
			}
		}
		printf("%d",p.top());
		p.pop();
		for(i=1;i<m;i++)
		{
			printf(" %d",p.top());
			p.pop();
		}
		printf("\n");
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值