1001. A+B Format

1001. A+B Format (20)-PAT甲级真题

Calculate a + b and output the sum in standard format — that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

题目大意:计算A+B的和,然后以每三位加一个"."的格式输出~。

解题思路
1、将a+b的值转化为string。:string str = to_string(a + b);
2、将字符串中的每一个字符压入栈,并设置计数器 count,每压入3个字符的同时压入一个','

代码如下:

#include <string>
#include <stack>
using namespace std;

int main() {
	int a, b, count=0;
	cin >> a >> b;
	string str = to_string(a + b);
	stack<char> stack1;
	for (int i = str.size()-1; i >= 0; i--)
	{
		stack1.push(str[i]);
		count++;
		if (str[0] != '-') {
			if (count == 3 && i != 0)
			{
				stack1.push(',');
				count = 0;
			}
		}
		else
		{
			if (count == 3 && i != 1 && i != 0)
			{
				stack1.push(',');
				count = 0;
			}
		}
		
	}
	while (stack1.size()!=0)
	{
		cout << stack1.top();
		stack1.pop();
	}
	return 0;
}

运行成功

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值