HDU2030_The Embarrassed Cryptographer_千进制、同余模

The Embarrassed Cryptographer

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 890    Accepted Submission(s): 295


Problem Description
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively. 
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.
 

Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
 

Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.
 

Sample Input
  
  
143 10 143 20 667 20 667 30 2573 30 2573 40 0 0
 

Sample Output
  
  
GOOD BAD 11 GOOD BAD 23 GOOD BAD 31

大致题意:

给出一个数字K,K不多于100位,判断是否存在一个素数,是K的一个因数,且小于给定的限制L。若存在,输出 BAD 和满足条件的素数。否则输出 GOOD 。


大体思路:

1)筛法求素数

2)以字符串的形式输入K,并转化为千进制整数

lenK=strlen(K);
		for(i=0;i<lenK;i++)
			k[(lenK+2-i)/3-1]=10*k[(lenK+2-i)/3-1]+K[i]-48;
		lenk=(lenK+2)/3;
3)  同余模法则 找因数

#include<cstdio>
#include<cstring>

const int Max=1000010;
int prime[Max]={0};

void Prime()
{
	for(int i=2;i<Max;i++){
		if(!prime[i]) prime[++prime[0]]=i;
		for(int j=1;prime[j]<Max/i;j++){
			prime[i*prime[j]]=1;
			if(i%prime[j]==0) break;
		}
	}
}

char K[110];
int k[35];

bool Test(int i,int lenk)
{
	int t=0,j;
	for(j=lenk-1;j>=0;j--)
		t=(1000*t+k[j])%prime[i];
	if(t) return 0;
	else return 1;
}

int main()
{
	Prime();

	//freopen("in.txt","r",stdin);
	int L,lenK,lenk,i;

	while(scanf(" %s %d",K,&L)&&L!=0){
		memset(k,0,sizeof(k));
//千进制转化
		lenK=strlen(K);
		for(i=0;i<lenK;i++)
			k[(lenK+2-i)/3-1]=10*k[(lenK+2-i)/3-1]+K[i]-48;
		lenk=(lenK+2)/3;
//检查
		for(i=1;prime[i]<L&&i<=prime[0];i++){
			if(Test(i,lenk)){
				printf("BAD %d\n",prime[i]);
				break;
			}
		}
		if(prime[i]>=L||i>prime[0]) printf("GOOD\n");

	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值